Sm Bus Controller

Discussion in 'Tech Help' started by corum, Jun 16, 2011.

  1. Offline

    corum Community Member

    Recently some of my USB ports been playing up not recognising mass storage devices and then I noticed my SM Bus Controller had the little yellow exclamation mark on it in device manager.

    So I got the cd for the motherboard, made sure I was logged in as administrator and reinstalled the chipset drivers which have the SM bus driver included. No luck. Says 'driver installation file is missing a necessary entry'.

    Tried installing the SM Bus driver on it's own. Same problem.
    Got latest drivers from ASUS for the chipset. Same problem.
    Got drivers from Intel. Same problem.
    Tried safe mode. Same problem.
    Tried many other things...always same problem.

    Wondered if anyone has had a similair issue and can maybe help me out here.

    (Vista 64, ASUS P5Q-E).
  2. Offline

    Tal The Architect

    Have you tried the latest version from the Asus website?
  3. Offline

    Fallanx Tactical Veteran

    You could also reset your bios; solved some issues on my older asus mb.
  4. Offline

    Fizzee Veteran BOON

    Had a similar issue with a restart loop with a USB drive connected. Disabled legacy USB in bios and now no problems.
  5. Offline

    corum Community Member

    Yes Tal I tried the latest drivers from Asus. No luck.
    Also disabled legacy USB Fizzee but didn't help.

    This is the error I get :
    Intel RCH10 Family SM Bus Controller - 3A30
    The driver installation file for this device is missing a necessary entry. This may be because the INF was written for Windows 95 or later (well ofc it was ffs)

Share This Page