TS connection issues

Discussion in 'Tech Help' started by Elfins, Nov 13, 2012.

  1. Offline

    Elfins Veteran BOON

    I have been using Teamspeak since I joined Boon, but ever since the latest update (3.0.9.x) the program has been failing on me. It either doesn't connect or it times me out after x minutes and keeps on reconnecting/dc'ing.

    I have tried changing firewall settings, new drivers, cleaning registry programs, new internet cable, uninstalling/reinstalling TS, running it in admin mode, even upgraded OS to windows 8 but the problem persists. If anyone has other ideas about what could be wrong please help, i'm getting highly frustrated with not being able to fully play and help in wvw raids.

    PC specs:
    MS Windows 8 pro-64bit, Intel Core i5 CPU 750 @ 2.67Ghz, 3.0 GB ram, ATI Radeon HD 5670.

    TS chatbox lines:
    <21:38:53> You dropped (connection lost)
    <21:38:53> Connection to server lost
    <21:38:55> Trying to resolve hostname <our ts servername>
    <21:38:55> Trying to connect to server on <our ts servername+port>
    <21:39:01> Failed to connect to server

    Thanks in advance.
  2. Offline

    Xelendar Veteran BOON

    Whats the Firewall/Antivirus you have installed?
  3. Offline

    Elfins Veteran BOON

    Xeno firewall Windows firewall and Avira free anti-virus.
  4. Offline

    Drexciyian Veteran BOON

    Try using this server ip 178.79.157.92:9988
  5. Offline

    Elfins Veteran BOON

    That seemed to work until late afternoon when the dc'ing kicked in again :/.
  6. Offline

    Tal The Architect

    Turn off xeno firewall. Whatever that is.
  7. Offline

    Elfins Veteran BOON

    Already did.
  8. Offline

    Kisiek Community Member

    Maby its your ISP. Dont you have any lags ore drops from the game?
  9. Offline

    Elfins Veteran BOON

    Lag almost none, drops from game yes - sometimes it freezes and requires hardboot of my pc to be able to do anything again.
  10. Offline

    Nerien "Bad Boy"

    Is it just the boon ts you're having a issue with or anything you may have had the chance to test?
  11. Offline

    Elfins Veteran BOON

    I must admit I have not tried logging into any other ts server since this problem started, as BOON's is the only one I need (I don't have any other ts server info anymore either).
  12. Offline

    Nariko Community Member

    Try this ts server:

    x x x there is no password


    P.s. If it works - and someasks - tell em you are me! they will never notice the difference in the voices xD
  13. Offline

    Elfins Veteran BOON

    Tried after I dc'ed from Boon's and it isn't working then same as for ours.
  14. Offline

    Nariko Community Member

    I am running out of things to come up with >-<

    That just sucks - and I can fully understand your frustration
  15. Offline

    Tal The Architect

    Did you upgrade from windows 7 to windows 8, or a fresh install?
  16. Offline

    Tal The Architect

  17. Offline

    Elfins Veteran BOON

    I upgraded to 8 from 7, and just uninstalled with geekuninstaller. Reinstalled TS but still the same problem :(
  18. Offline

    Nerien "Bad Boy"

    Might have something to do with a router/software firewall and it not forwarding ports properly for TS then.
  19. Offline

    Elfins Veteran BOON

    Any idea if there's a more specific software firewall than the Windows one I might not know about? Disabling the Windows one doesn't help -Xeno Firewall is disabled permanently- and when Windows firewall is on I made sure TS has access through it as incoming connection with reach for all ports per protocol (TCP and UDP - I haven't specified numbers for the ports).
  20. Offline

    Tal The Architect

    Have you tried checking your Windows Firewall settings, TS might be in there and blocked somehow. It will be under advanced firewall settings.

Share This Page

Facebook: